firefox

追加アプリケーションパッケージ、PETやSFSなどの話題です

モデレータ: 暇人, YoN, nyu

ふうせん Fu-sen.
記事: 561
登録日時: 13/09/17(火) 10:01

Re: firefox

投稿記事 by ふうせん Fu-sen. »

Ubuntu リボジトリの Firefox も 28.0+build2 へ更新されている事を確認しました。
これは Precise-571JP/550JP の パッケージマネージャ に反映されています。
パッケージマネージャの設定 - ただちに更新 で最新版が一覧に表示されるようになります。
ふうせん Fu-sen. ( old: 2 8 6 )
ふうせん Fu-sen.
記事: 561
登録日時: 13/09/17(火) 10:01

Re: firefox

投稿記事 by ふうせん Fu-sen. »

Firefox 29 が公開されはじめています。自動更新はすでに効いているようです。

ftp://ftp.mozilla.org/pub/mozilla.org/f ... ases/29.0/
(http だと beta 版案内になるため、ftp にしてあります。Opera では表示できないかも?)

このバージョンより UI の変更が生じていますので、ご注意下さい。
firefox-29.jpg
添付ファイルを見るにはパーミッションが必要です
ふうせん Fu-sen. ( old: 2 8 6 )
ふうせん Fu-sen.
記事: 561
登録日時: 13/09/17(火) 10:01

Re: firefox

投稿記事 by ふうせん Fu-sen. »

Ubuntu パッケージが Firefox 29.0 になりました。
Precise-571JP・550JP のパッケージマネージャに検出される
Ubuntu 12.04 Precise の .deb パッケージは
29.0+build1-0ubuntu0.12.04.2 となっています。
上記投稿の通り、更新すると UI の変化が発生します。

また Dpup Wheezy は Debian パッケージとは別に独自に Firefox を搭載していて、
自動更新機能で 29.0 に更新されます。
DebianDog は Iceweasel が apt 提供で、こちらは現在 24.5.0、
Slacko が参照する Slackware パッケージの ESR 版も同様に 24.5.0 で、
これらで UI 変化が生じるのはもう少し先になるでしょう。
更新されるタイミングは Firefox 32 になるかと思います。
ふうせん Fu-sen. ( old: 2 8 6 )
ふうせん Fu-sen.
記事: 561
登録日時: 13/09/17(火) 10:01

Re: firefox

投稿記事 by ふうせん Fu-sen. »

Mozilla 公開の Firefox が 29.0.1 に更新されています。

ftp://ftp.mozilla.org/pub/mozilla.org/f ... es/29.0.1/

29.0 でバグがいくつか新たに発生しているので、それのバグ修正が行われているようですね。

今後自動更新および Ubuntu パッケージ等に更新が入ります。
ふうせん Fu-sen. ( old: 2 8 6 )
ふうせん Fu-sen.
記事: 561
登録日時: 13/09/17(火) 10:01

Re: firefox

投稿記事 by ふうせん Fu-sen. »

Mozilla 公開の Firefox が 30.0 に更新されました。

ftp://ftp.mozilla.org/pub/mozilla.org/f ... ases/30.0/

……で、Ubuntu リボジトリも更新されはじまっています。

http://security.ubuntu.com/ubuntu/pool/ ... x/?C=M;O=D

これは Precise-571JP/550JP の パッケージマネージャ に反映されます。
パッケージマネージャの設定 - ただちに更新 で最新版が一覧に表示されるようになります。
この投稿時はまだ反映されていません。下記のバージョン表記が変化してからになるでしょう。

http://packages.ubuntu.com/ja/precise/firefox

待てない人は .deb パッケージをダウンロード・インストールしても良いです。
firefox_30.0+build1-0ubuntu0.12.04.3.i386.deb
firefox-locale-ja_30.0+build1-0ubuntu0.12.04.3.i386.deb

となります。
ふうせん Fu-sen. ( old: 2 8 6 )
kochan
記事: 41
登録日時: 14/04/25(金) 17:27

Re: firefox

投稿記事 by kochan »

firefox-portable-0.6では、自動的にfirefox30.0がインストールされました。
ふうせん Fu-sen.
記事: 561
登録日時: 13/09/17(火) 10:01

Re: firefox

投稿記事 by ふうせん Fu-sen. »

Firefox が 33.0 に更新されました。
ftp://ftp.mozilla.org/pub/mozilla.org/f ... ases/33.0/

Ubuntu パッケージは反映されています。
Precise-571JP・550JP はすでにインストール済みの場合、一度アンインストールし、
パッケージマネージャを最新に更新を行ってからインストールするか、
下記の URL から .deb パッケージをダウンロードし、インストールしてください。
パッケージは firefoxfirefox-locale-ja です。
http://packages.ubuntu.com/ja/precise/i ... x/download

Slacko は最初から入っている Firefox が自動更新します。
「Firefox について」を参照するとすぐに更新されます。

Wheezy・DebianDog の Debian 系は Iceweasel なので、1日位遅れて更新されるかと思います。

なお、この方法でのインストールは Puppy のために設定を調整する必要がある場合があります。
Puppy に最適化された .pet パッケージや firefox-portable を使用すると快適でしょう。
これらの場合は自動更新になっているかと思います。
ふうせん Fu-sen. ( old: 2 8 6 )
ふうせん Fu-sen.
記事: 561
登録日時: 13/09/17(火) 10:01

Re: firefox

投稿記事 by ふうせん Fu-sen. »

SSL 3.0 の脆弱性 POODLE が 14 日に公開されています。
対策として SSL 3.0 を無効にする事が推奨されています。

Firefox では11月公開予定の Firefox 34 で SSL 3.0 無効をデフォルトにする予定ですが、
すぐに無効にする方法があります。どちらかを行って下さい。
POODLE 関連の情報は別トピックでまとめています。
viewtopic.php?t=2755
ふうせん Fu-sen. ( old: 2 8 6 )
kochan
記事: 41
登録日時: 14/04/25(金) 17:27

Re: firefox

投稿記事 by kochan »

過去のfirefoxの.sfsファイルを参考にして、Firefoxのバージョンのみを最新のものに差し替えました。

firefox-31.3.0-esr-ja.sfs(47M)
https://docs.google.com/uc?id=0B6OuFgZ4 ... t=download

firefox-34.0.5-ja.sfs(53M)
https://docs.google.com/uc?id=0B6OuFgZ4 ... t=download

571JPで動作確認しました。
kochan
記事: 41
登録日時: 14/04/25(金) 17:27

Re: firefox

投稿記事 by kochan »

更新しました。
firefox-37.0.1-ja.sfs (54M)
https://drive.google.com/file/d/0B6OuFg ... sp=sharing

571JPで動作確認しました。
thinkpadnerd
記事: 1552
登録日時: 15/10/25(日) 14:00

Re: firefox

投稿記事 by thinkpadnerd »

このスレッドの以前の記事に puppy 4系で最新の Firefox を使えるようにする方法が紹介されていました。

> Firefox を利用するには、最低限以下のライブラリまたはパッケージが必要です。
>  ・GTK+ 2.18 以上
>  ・GLib 2.22 以上
>  ・Pango 1.14 以上
>  ・X.Org 1.0 以上 (1.7 以上を推奨)
>  ・libstdc++ 4.3 以上

私の環境(puppy 4.1.2 に若干アップデートを施したもの)では、GTK+ 以外は条件を満たしていたので、gtk+-2.18.3-p4.pet をインストールしたら、Firefox 最新版が動きました。とりあえず yahoo や youtube が見れることを確認しました。
私のマシンは、puppy 4.1.2 日本語版に以下を追加したもの。以下のファイルは http://412collection.neocities.org/index.html からいただいたものです。この状態では Firefox 17 まで動きます。

glib-2.22.2-i486.pet
glibc-2.10.1.pet
glibc_locales-2.10.1.pet (これを入れた後、time zone を"Asia Tokyo"に再設定)
gtkdialog4-246-w5.pet
puppy412-flash-fullscreen-fix.pet (これは関係ないかもしれませんが、全画面表示に必要)

なぜに未だ puppy 4系? と思う方もいるでしょうが、puppy 5.7.1 ではモデムが動かなかったので、4系を使っています。fax 機能を利用するためです。

ThinkPad T43
CPU Pentium M 1.86GHz
RAM 1.5 GB
ThinkPad X121e (Precise 571 / Tahr 605 / Tahr64 606 / Xenial 7.5 / Bionic32)
CPU AMD C-50 1.0GHz, RAM 4GB
ThinkPad L440 (Xenial 7.5 / Bionic64 / Fossa64)
CPU intel Celeron 2950M 2.0GHz, RAM 4GB
thinkpadnerd
記事: 1552
登録日時: 15/10/25(日) 14:00

Re: firefox

投稿記事 by thinkpadnerd »

前の記事で、Puppy 4.1.2 で最新の Firefox が使える、ということを書きました。Firefox 42 が特に問題なく動いています。しかし、gtk+ をバージョンアップしたことによる副作用なのか、日本語入力の際に変換候補が、入力位置から離れた場所に表示されるようになりました。非常に困る、というものではないのですが、ちょっといやなので、直す方法をさぐっていました。私は scim-anthy を使っています。

正しい対処の仕方なのかわかりませんが、ネットで調べたことを参考に次のようにしました。
scim-bridge-0.4.16-pup4.pet をインストールする。 /root/.xinitrc を編集する。

export GTK_IM_MODULE="scim"
export QT_IM_MODULE="scim"
とあるのを
export GTK_IM_MODULE="scim-bridge"
export QT_IM_MODULE="scim-bridge"
とする。

結果、Firefox や OpenOffice で変換候補が正常に表示されるようになりました。テキストエディタでは leafpad は正常に表示されますが、geany はだめです。
ThinkPad X121e (Precise 571 / Tahr 605 / Tahr64 606 / Xenial 7.5 / Bionic32)
CPU AMD C-50 1.0GHz, RAM 4GB
ThinkPad L440 (Xenial 7.5 / Bionic64 / Fossa64)
CPU intel Celeron 2950M 2.0GHz, RAM 4GB
thinkpadnerd
記事: 1552
登録日時: 15/10/25(日) 14:00

Re: firefox

投稿記事 by thinkpadnerd »

puppy 4.1.2 での Firefox ですが、Firefox 43 ではブラウザを閉じた後も、30秒くらいメモリ上に残り、その後クラッシュレポートのウインドウが表示されるという奇妙な現象に見舞われました。web の閲覧中は何も問題は生じないのですが。

Firefox 44 は起動しません。システム要件(英語サイト)を見てみると、gtk+ のバージョンが上がっています。ライブラリをバージョンアップした puppy 4.1.2 及び同等のシステムでは、Firefox 42 が安定して動く最後のバージョンかもしれません。
ThinkPad X121e (Precise 571 / Tahr 605 / Tahr64 606 / Xenial 7.5 / Bionic32)
CPU AMD C-50 1.0GHz, RAM 4GB
ThinkPad L440 (Xenial 7.5 / Bionic64 / Fossa64)
CPU intel Celeron 2950M 2.0GHz, RAM 4GB
thinkpadnerd
記事: 1552
登録日時: 15/10/25(日) 14:00

Re: firefox

投稿記事 by thinkpadnerd »

puppy 4.1.2 で Firefox 44 を起動すべく、実験をしました。

これまでのものに加えて以下のパッケージをインストールしました。

libgtk-3.6.0-u-20121116.pet
dbus-1.6.8-up-20121102.pet (dbus-1.2.14-i486.pet と置き換え)
fontconfig-2.11.1-i486.pet

(dbus-glib は dbus-glib-0.80-i486.pet を使用)

Firefox 44 が起動しました。端末から起動すると、フォント関連の warning が出ますが、ちゃんと動きます。ブラウザを閉じても、しばらくメモリ上に残って、その後クラッシュレポートのウインドウが表示される点は Firefox 43 の場合と同じです。

システムのフォントがややぼやけた感じになりました。これはフォントの設定によるもので、調整が必要です。その他は、私の環境では副作用のようなものは出ていません。

最近の Firefox は tar を展開すると 100MB くらいになり、メモリの消費も多いです。今でも puppy 4系を使っている人は、物理メモリが少ないなど、特別な事情を抱えていると思うので、Firefox 44 が動いてもメリットはほとんどないでしょう。

もし試される場合は、意図せぬ結果を招くといけないので、予め save file のバックアップを取っておいてください。

追記
フォントの見え方が変わった原因の一つは、dpi が正しく設定されていないためと思われます。
dpi の調整

/etc/fonts/local.conf に以下の記述を追加

<match target="pattern">
<edit name="dpi" mode="assign"><double>75</double></edit>
</match>

dpi の数値は /var/log/Xorg.0.log から拾いました。ハードウエアにより異なります。
ThinkPad X121e (Precise 571 / Tahr 605 / Tahr64 606 / Xenial 7.5 / Bionic32)
CPU AMD C-50 1.0GHz, RAM 4GB
ThinkPad L440 (Xenial 7.5 / Bionic64 / Fossa64)
CPU intel Celeron 2950M 2.0GHz, RAM 4GB
thinkpadnerd
記事: 1552
登録日時: 15/10/25(日) 14:00

Re: firefox

投稿記事 by thinkpadnerd »

Puppy 4.1.2 での Firefox
Firefox 45 がリリースされました。44 よりシステム要件が下がっています。

・Firefox 44 system requirements
Firefox will not run at all without the following libraries or packages:

GTK+ 3.4 or higher
GLib 2.22 or higher
Pango 1.14 or higher
X.Org 1.0 or higher (1.7 or higher is recommended)
libstdc++ 4.3 or higher

(ここに書かれていること以外にも、システム要件が存在することは明らかです。)

・Firefox 45 system requirements
Firefox will not run at all without the following libraries or packages:

GTK+ 2.18 or higher
GLib 2.22 or higher
Pango 1.14 or higher
X.Org 1.0 or higher (1.7 or higher is recommended)
libstdc++ 4.3 or higher

(GTK+ のバージョンが下がっています。)

Firefox 45 に関してテストをしてみました。

libgtk-3.6.0-u-20121116.pet を削除 → 起動する
dbus を以前のものに戻す → 起動しない
fontconfig-2.11.1-i486.pet を削除(元のバージョンに戻す) → 起動しない

dbus と fontconfig のバージョンアップは、やはり必要です。
ThinkPad X121e (Precise 571 / Tahr 605 / Tahr64 606 / Xenial 7.5 / Bionic32)
CPU AMD C-50 1.0GHz, RAM 4GB
ThinkPad L440 (Xenial 7.5 / Bionic64 / Fossa64)
CPU intel Celeron 2950M 2.0GHz, RAM 4GB
返信する