4.3.1JP-RC3(+SP3.1118)

4.X系の開発

モデレータ: 暇人, YoN, nyu

アバター
暇人
記事: 2392
登録日時: 07/08/12(日) 23:33
お住まい: 埼玉県xx市並4
連絡する:

Re: 4.3.1JP-RC3

投稿記事 by 暇人 »

区別したことなかったけど、gzipとzipは互換性が無いの?
マジ?
ところで、Windows95以来(long)ファイル名は UTF-8ではないのか?Zipに固めるときにsjis(cp932)に変換するの?
http://www-06.ibm.com/jp/domino01/mkt/c ... t-007ACA9B
まさにその通りだそう。
管理人見習い
NEC Express5800 S70/SR G6950 2.8GHz/1G
lenovo S10-3 AtomN450 1.66G/1G
暇人/貳馬力/2CV
アバター
シノバー
記事: 3138
登録日時: 09/03/21(土) 00:05
連絡する:

SJIS(CP932)

投稿記事 by シノバー »

ふむふむ。
fatでもlong filename はUTF-8ですよね。

ところで、pnethoodですが、相手のhost名が日本語だとアクセスできないですね。これはしかたがないのか?
The bar master, Shino's Bar
http://shinobar.net/
アバター
シノバー
記事: 3138
登録日時: 09/03/21(土) 00:05
連絡する:

Re: abiword-2.7.8-p3jp

投稿記事 by シノバー »

ベースは2.7.8-p3ではなくabiword-2.7.8-p4の間違いでした。
シノバー さんが書きました:/usr/lib/abiword-2.6、/usr/share/abiword-2.6 は不要です。
おっと、前者にはプラグイン(600kB)が、後者には辞書(2.4MB)がありました。abiword-2.7.8-p4のパッケージには欠けているものです。
いずれもインストール後に追加することもできそうです。

プラグインは各種ファイルや画像のインポートなど必須そうなので、はじめから入れておくとして(2.7.8で動くのか要テスト)。

辞書(2.4MB)はどうしましょう?英語とメキシカンスパニッシュなど北米とオーストラリア限定みたいだし、大きいので日本語版からは外しておき、後からオプションでインストール可能という形でどうかなあ?
The bar master, Shino's Bar
http://shinobar.net/
新谷
記事: 934
登録日時: 08/10/09(木) 18:52
お住まい: 大阪

Re: pupzip

投稿記事 by 新谷 »

WindowsXPで作成したファイルで、ざっとテストしてみた限りでは、日本語文字化けはしないなぁ....。
ちょっとテストファイルが単純過ぎでしょうか。

gzipとzipは互換性が無さそう....。
添付ファイルを見るにはパーミッションが必要です
新谷
記事: 934
登録日時: 08/10/09(木) 18:52
お住まい: 大阪

Re: 4.3.1JP-RC3

投稿記事 by 新谷 »

service_pack431JP-RC-3.pet をテストしてますが、フォーラムで話し合い中のもの(yaf-splashとか)以外には、今のところ不具合はありません。
シノバー さんが書きました:辞書(2.4MB)はどうしましょう?英語とメキシカンスパニッシュなど北米とオーストラリア限定みたいだし、大きいので日本語版からは外しておき、後からオプションでインストール可能という形でどうかなあ?
いいんじゃないでしょうか :o
アバター
シノバー
記事: 3138
登録日時: 09/03/21(土) 00:05
連絡する:

Re: scim

投稿記事 by シノバー »

シノバー さんが書きました:scimも壊れていることを発見。こちらは 4.30JPbeta(9月25日)以来。
viewtopic.php?f=32&t=1447&p=10099#p10099
ファイルが壊れていたわけではありませんでした。
/etc/gtk-2.0/gtk.immodules に9月25日に行った次の変更が影響していたようです。もとに戻すと pdf-writerが正常に動作しました。

4.3.1Beta(9月25日)以来のgtk.immodules の一部
"/usr/lib/gtk-2.0/2.10.0/immodules/im-xim.so"
"xim" "X Input Method" "gtk20" "/usr/share/locale" "*"

"/usr/lib/gtk-2.0/immodules/im-scim.so"
"scim" "SCIM Input Method" "scim" "/usr/share/locale" "*"
↓もとの gtk.immodules (pdf-writer正常動作)
"/usr/lib/gtk-2.0/2.10.0/immodules/im-xim.so"
"xim" "X Input Method" "gtk20" "/usr/share/locale" "ko:ja:th:zh"

"/usr/lib/gtk-2.0/immodules/im-scim.so"
"scim" "SCIM Input Method" "scim" "/usr/share/locale" "ja:ko:zh"
「*」を指定したのは、どのロケールでも scimが動作するためのものだったのですが、一部のアプリでは不具合が起きるようです。
The bar master, Shino's Bar
http://shinobar.net/
アバター
シノバー
記事: 3138
登録日時: 09/03/21(土) 00:05
連絡する:

Re: abiword-2.7.8-p4jp

投稿記事 by シノバー »

シノバー さんが書きました:プラグインは各種ファイルや画像のインポートなど必須そうなので、はじめから入れておくとして(2.7.8で動くのか要テスト)。
どうもこれらのプラグインはabiword-2.7系では必要なさそうです。たぶん本体に組み込まれている。

プラグインなしのabiword-2.7.8-p4jpで、Windowsのどのバージョンか分からないが wrod文書を読めることだけは確認しました。
PDFはもともと読めないみたいとか、よく分からないところもあります。
The bar master, Shino's Bar
http://shinobar.net/
アバター
シノバー
記事: 3138
登録日時: 09/03/21(土) 00:05
連絡する:

SP3.1114

投稿記事 by シノバー »

↓SP3.1118が出ています。
viewtopic.php?f=28&t=1444&start=60#p10331

ということで、
service_pack431JP-RC-3.1114.pet(SP3.1114) を用意しました。
こちらから
scimは不要なので入れてません。abiwordはSP3.1113と同じく辞書、プラグインとも入れてません。

4.3.1JP-RC3に適用してください。
4.3.1JP-RC3リリース以降の修正をすべて含んでいるので、他の修正PETはあらかじめ外しておいてください。
SP3.1114適用後、 /usr/bin/abiword-binは不要です。邪魔なら削除してください。

*SP3.1113 の内容(SP3.1114にも同梱)
  • abiword-2.7.8-p4jp
  • (scim-1.4.9.pup4.4.2.2.1←SP3.1114からは削除
    ただし /etc/gtk-2.0/gtk.immodules を変更)
  • pupsaveconfig-1.6.1
  • grub4dosconfig(ヘルプファイルのみ)
  • inkspace.mo
  • glipper.mo
  • Axel(puppydownloader)
  • pdvdrsab
  • isomaster.mo
  • filemnt
  • yaf-splash
  • gftp.mo
  • gparted.mo
  • release-4.3.1JP.htm(和文/英文)
*SP3.1114で追加
  • dialog(UTF-8対応のためdebianのものと差し替え)
  • yaf-splash(更新)
  • L10nSwitcher(コンソール対応)
  • meeview ←誤り。/usr/bin/meeboviewを削除し、/usr/bin/meeview を meeboview とリネームしてください。
  • alsaconf
  • firewallinstall
  • save2flash
  • snapmergepuppy
  • bootflash
  • modemprobe
  • modemtest
  • pupdial
  • grubconfig
  • ppupyinstaller
  • release-4.3.1JP.htm(更新)
最後に編集したユーザー シノバー [ 09/11/18(水) 19:25 ], 累計 3 回
The bar master, Shino's Bar
http://shinobar.net/
keitan
記事: 107
登録日時: 08/02/28(木) 00:04
お住まい: 東京

Re: 4.3.1JP-RC3

投稿記事 by keitan »

4.3.1JP-(SP3.1114) ありがとうございます
いまのところ 快適度100プラスです
abiwordのバージョン番号ないのは仕様ですよね
添付ファイルを見るにはパーミッションが必要です
非力PC友の会
TOSHIBA Satellite AW1 Celeron 2.4GHz/512MB/30GB
4.30JP(SP2)(Frugal)&koropup1.09
IBM ThinkPad X21 Pentium III 700MHz/384MB/10GB
4.304.30retroJP(SP2)(Frugal)&koropup1.09
アバター
シノバー
記事: 3138
登録日時: 09/03/21(土) 00:05
連絡する:

Re: 4.3.1JP-RC3

投稿記事 by シノバー »

keitanさん、ありがとうございます。
keitan さんが書きました:abiwordのバージョン番号ないのは仕様ですよね
出ませんね。

Abiword、バージョンアップして問題がないのかどうか不安です。
テストよろしくお願いします>みなさま
The bar master, Shino's Bar
http://shinobar.net/
アバター
みのむし
記事: 1164
登録日時: 08/09/10(水) 13:56
お住まい: 福岡市中央区草香江1-2-40-101号
連絡する:

Re: 4.3.1JP-RC3

投稿記事 by みのむし »

>keitan さんが書きました:
>abiwordのバージョン番号ないのは仕様ですよね

>出ませんね。
>...
>テストよろしくお願いします>みなさま

私の環境(SP3.1114適用)では、ヘルプ(H)|abiwordについて(A)...
「abiword-bin 2.6.3」
と表示されています。
ちょっとしか使ってませんが、特に問題は見当たらないようです。
みのむし
Notebook PC HP G62
CPU: Intel(R) Core(TM)i5 M450 @ 2.40GHz
MEM: 4GB
Puppy Linux Quickset 5.1.1 JP
PC内蔵無線LANデバイス RTL8171(r8192se_pci)
アバター
シノバー
記事: 3138
登録日時: 09/03/21(土) 00:05
連絡する:

Abiword(SP3.1114適用)

投稿記事 by シノバー »

みのむし さんが書きました:私の環境(SP3.1114適用)では、ヘルプ(H)|abiwordについて(A)...
「abiword-bin 2.6.3」
と表示されています。
/usr/local/bin/defaultwordprocesser が、他のもの(OpenOfficeなど)になっているのではないでしょうか?

コード: 全て選択

#!/bin/sh
exec abiword.sh "$@"
あるいは /usr/share/applications/Abiword-wordprocesser.desktopの中で

コード: 全て選択

Exec=abiword.sh
端末からは次のコマンドで実行してください。

コード: 全て選択

abiword.sh
それとも /usr/bin/abiword 自身が更新されていない?

コード: 全て選択

# ls -l /usr/bin/abiword
-rwxr-xr-x 1 root root 5647140 2009-08-06 00:40 /usr/bin/abiword
The bar master, Shino's Bar
http://shinobar.net/
アバター
YoN
Site Admin
記事: 1239
登録日時: 07/04/01(日) 08:00
お住まい: 信州

service_pack431JP-RC-3.1114.pet

投稿記事 by YoN »

すごい、すごい! シノバーさんご苦労様です。
alsaconf が日本語になったー :o
ありがとうございます。
[Puppy4.1.2-retro-JP] EPSON Endeavor MT-3500
Celeron 533MHz 256MB
[Lupu-5.0.1 LiveCD + lang_support_ja-1.4.sfs] SOTEC Whitney System CR Board
Celeron 766MHz 512MB
新谷
記事: 934
登録日時: 08/10/09(木) 18:52
お住まい: 大阪

abiword

投稿記事 by 新谷 »

ヘルプのヴァージョン番号表示は、うちでもないですね。仕様なのかしら。
abiword 自体はテストしてみた限りでは問題ありません。
みのむし さんが書きました:私の環境(SP3.1114適用)では、ヘルプ(H)|abiwordについて(A)...
「abiword-bin 2.6.3」
と表示されています。
サービスパック導入後はabiwordのヴァージョンは2.7.8になるのでは?

コード: 全て選択

# abiword --version
2.7.8
確信はないですが、アップグレードに失敗しているのでは?
アバター
みのむし
記事: 1164
登録日時: 08/09/10(水) 13:56
お住まい: 福岡市中央区草香江1-2-40-101号
連絡する:

Re: 4.3.1JP-RC3

投稿記事 by みのむし »

シノバーさん、新谷さんお手数をお掛けしました。
その後、色々といじって 2.7.8 になりました。
みのむし
Notebook PC HP G62
CPU: Intel(R) Core(TM)i5 M450 @ 2.40GHz
MEM: 4GB
Puppy Linux Quickset 5.1.1 JP
PC内蔵無線LANデバイス RTL8171(r8192se_pci)
返信する